DokuWiki

IMPORTANT!

This is the old issue tracking system for DokuWiki. Issues can not be added here anymore. Pleaser refer to https://github.com/splitbrain/dokuwiki/issues for the new system.

IMPORTANT!
Tasklist

FS#2521 - Uploading files fails if single sign on is used

Attached to Project: DokuWiki
Opened by K.-M. Hansche (loxley) - Tuesday, 08 May 2012, 05:32 GMT
Last edited by Guy Brand (bug) - Wednesday, 31 July 2013, 13:22 GMT
Task Type Bug Report
Category Media Management
Status Closed
Assigned To No-one
Operating System Linux
Severity High
Priority Normal
Reported Version 2012-01-25 "Angua"
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Uploading files fails if the AD auth-backend is configured to use sso. The mediamanager uploads the file and then just says "failed", no further message is given.

The following actions fixed the problem:
1. Disable sso. (Firefox 3.6, Firefox 12, Chrome)
2. Activate Firebug. (Firefox 3.6, 12)
3. Install LiveHTTPHeaders (Firefox 3.6.x, 12)

I do use XmlHttpRequest in other applications on the same server (albeit not with ad.php) and don't experience any problems.

The problem is hard to debug, but if you need any information I'll be happy to give it a try.

Regards

Niki



This task depends upon

Closed by  Guy Brand (bug)
Wednesday, 31 July 2013, 13:22 GMT
Reason for closing:  None
Additional comments about closing:  Workaround exists
Comment by K.-M. Hansche (loxley) - Friday, 25 May 2012, 13:17 GMT
Please see  FS#2527 , which seems to be related.

I "fixed" the problem by disabling authentification for ajax.php via a files entry in .htaccess.
Comment by Andreas Gohr (andi) - Saturday, 16 February 2013, 15:11 GMT
judging from  FS#2527  this is a problem on IE only?
Comment by K.-M. Hansche (loxley) - Monday, 18 February 2013, 05:34 GMT
Nope, this affected chrome and Firefox (didn’t test others).
Comment by Valentin Kim (imortkz) - Tuesday, 19 March 2013, 10:43 GMT
> I "fixed" the problem by disabling authentification for ajax.php via a files entry in .htaccess.

Please, can you write down, how did you do it?

I have exactly same problem: dokuwiki with AD + SSO config, and "failed" to upload any file via standart manager.
Comment by K.-M. Hansche (loxley) - Tuesday, 19 March 2013, 11:30 GMT
I added
<files ajax.php>
Satisfy Any
Allow from all
</files>
to the .htaccess.
Comment by Valentin Kim (imortkz) - Tuesday, 19 March 2013, 11:33 GMT
> I "fixed" the problem by disabling authentification for ajax.php via a files entry in .htaccess.

Please, can you write down, how did you do it?

I have exactly same problem: dokuwiki with AD + SSO config, and "failed" to upload any file via standart manager.
Comment by Valentin Kim (imortkz) - Tuesday, 19 March 2013, 11:34 GMT
Thank you, it's worked!
Comment by Guy Brand (bug) - Wednesday, 31 July 2013, 13:22 GMT
Closing this issue, as there is a workaround for Angua release. If the issue still appears in Weatherwax, feel free to ask for reopening this issue.

Loading...