DokuWiki

IMPORTANT!

This is the old issue tracking system for DokuWiki. Issues can not be added here anymore. Pleaser refer to https://github.com/splitbrain/dokuwiki/issues for the new system.

IMPORTANT!
Tasklist

FS#2472 - Large files fail to upload on some browsers

Attached to Project: DokuWiki
Opened by Chris (musicalvegan0) - Wednesday, 21 March 2012, 19:51 GMT
Task Type Bug Report
Category ACL & Authentication
Status Unconfirmed
Assigned To No-one
Operating System All
Severity High
Priority Normal
Reported Version 2012-01-25 "Angua"
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 2
Private No

Details

Uploading files of around 25MB or larger (though perhaps smaller) fail on certain browsers. The File Uploader only returns the message "fail." Small uploads succeed all the time.

'upload_max_filesize' and 'post_max_size' are both set to '1024M' in php.ini.
'LimitRequestBody' is set to '1073741824' in Apache's php.conf.

Tested on:
Ubunutu 11.10, Chromium 17.0.963.79 with Flash 11.1.102 and Firefox 10.0.2 with Flash 11.1.102 (FAIL, In Firefox, the tab crashes.)
Windows XP, Chrome 17.0.963.79 with Flash 11.1.102 (FAIL, In Chrome, the tab crashes.)
Windows XP, IE8 - Flash 10.3.183.7 (SUCCESS)

Hosting platform:
CentOS 6.2 with Apache 2.2.15

I've tested this with a 25MB zip file, an 80MB zip file, an 80MB tar.gz file, and a 600MB ISO image.

I'm assuming this is a bug with the flash uploader or the flash player and not server settings as it works in IE and other browsers tend to crash for extremely large uploads (600MB).

This is a particularly painful bug for us as we use DokuWiki to store equipment documentation and firmware that is often greater than 25MB.
This task depends upon

Comment by Matthias Schulte (lupo49) - Friday, 20 April 2012, 18:01 GMT
And the HTML uploader works fine when uploading large files? It fails just with the flash one?
Comment by Chris (musicalvegan0) - Friday, 20 April 2012, 18:12 GMT
I've not tried to use the HTML uploader on the current version as it seems to have been removed? Is there a way to enable it? On previous DokuWiki versions with the HTML uploader, large files were never a problem.
Comment by Matthias Schulte (lupo49) - Friday, 20 April 2012, 18:33 GMT
No, it is still there. The flash uploader has been removed in the latest version. It is only available as a plugin.

The new HTML uploader displays a button labelled "Select files" or you can just drag and drop the files into the upload are to upload files.
Comment by Chris (musicalvegan0) - Friday, 20 April 2012, 19:17 GMT
I see. I just assumed that this uploader was flash-based (given there was, at one point a flash uploader, I guess)- my mistake. However, the current uploader is the same uploader I was using at the time I reported the bug.

I just tried uploading again on the latest version and the problem still persists.
Comment by Matthias Schulte (lupo49) - Tuesday, 24 April 2012, 18:14 GMT
Are there any related entries in your webservers log (error) file?

Please also have a look at https://bugs.dokuwiki.org/index.php?do=details&task_id=2345
Comment by Chris (musicalvegan0) - Tuesday, 24 April 2012, 18:58 GMT
I looked at https://bugs.dokuwiki.org/index.php?do=details&task_id=2345 and can confirm this bug does not apply to me as no data is ever saved to the dokuwiki data directory.

After examining the error logs, this message appears in my apache error logs:
[Tue Apr 24 14:42:58 2012] [error] [client BLAH] PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 33032001 bytes) in Unknown on line 0, referer: https://BLAH.org/doku/doku.php/it:samba?do=media

So, I increased the memory limit in php.ini to 128M from 32M. The same error appears:
[Tue Apr 24 14:45:36 2012] [error] [client BLAH] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 87962417 bytes) in Unknown on line 0, referer: https://BLAH.org/doku/doku.php/it:samba?do=media

Interestingly enough, when I change the limit 256M, the error message changed slightly:
[Tue Apr 24 14:55:37 2012] [error] [client BLAH] PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 311296 bytes) in /var/www/html/tools/doku/inc/utf8.php on line 1025, referer: https://BLAH.org/doku/doku.php/it:samba?do=media
Comment by Matthias Schulte (lupo49) - Wednesday, 25 April 2012, 18:52 GMT
And when setting it to 512 MB?
Comment by Chris (musicalvegan0) - Wednesday, 25 April 2012, 19:03 GMT
When setting it to 512MB, the bug disappears. This does not seem to be an acceptable workaround, however, as 512 MB much too high for any web process to take up. Similarly, why does IE not demonstrate the bug when the setting is normal (32MB)?
Comment by Arjen (EnigmA-X) - Saturday, 23 March 2013, 15:26 GMT
I have run into the exact same issue. Running apache on Debian 5 with suhosin patch. Did all the proper changes to ini files, to be able to upload files up to 128M in size.

The dokuwiki uploader shows the max upload size as 128MB correctly. However, uploading a 53.7MB file fails with Firefox 19.0.2 and Chrome 25.0.1364.172 m. Using IE 9 works flawlessly. It looks like there is some JS being used, maybe the issue is in there?

Loading...